M
← Back to status

Server accessibility issue | rs205.nsresponse.com

Resolved Jun 29, 2026 08:46 UTC

Incident Updates

  • Resolved Jun 29, 2026 12:02 UTC

    We've now resolved the incident. Thanks for your patience.

  • Resolved Jun 29, 2026 08:46 UTC

    Some clients might experience some issues accessing the server rs205.nsresponse.com. Our infrastructure team are working on this as a priority to resolve this matter. If you need any assistance in the immediate, please reach out to our Customer Care Team.