M
← Back to status

Smartermail latency

Resolved Jun 29, 2026 08:23 UTC

Incident Updates

  • Resolved Jun 30, 2026 06:46 UTC

    Our infrastructure team have confirmed that the issue has now been resolved. We want to thank our clients for the patience they've had whilst our team was working on this resolution and apologise again for any of the inconveniences caused. If you have further issues please don't hesitate to contact us.

  • Resolved Jun 29, 2026 21:40 UTC

    The affected SmarterMail servers have been successfully restored, and services are now operating normally. Our infrastructure team continues to closely monitor the environment while the SmarterMail team continues working to prevent this issue from occurring again. If you continue to experience any issues, please do not hesitate to contact our support team. Thank you for your patience.

  • Resolved Jun 29, 2026 13:59 UTC

    Our team is still actively working on the Smartermail service. We appreciate your patience during this time.

  • Resolved Jun 29, 2026 08:23 UTC

    We are aware of a few customers having intermittent disruptions connected to their Smartermail service. Our infrastructure team are working on this as a priority to resolve this matter. If you need any assistance in the immediate, please reach out to our Customer Care Team.