M
← Back to status

Enhance - Server Latency - s12716.bom1.stableserver.net

Resolved Jun 8, 2026 11:35 UTC

Incident Updates

  • Resolved Jun 8, 2026 12:13 UTC

    We've now resolved the incident. Thanks for your patience.

  • Resolved Jun 8, 2026 11:35 UTC

    We are aware of an issue affecting web services on Enhance server s12716.bom1.stableserver.net. Our infrastructure team has identified the cause and is actively working to restore services in full. We will provide further updates as progress is made. If you need any assistance in the immediate, please reach out to our support team.