M
← Back to status

Server latency | s13839.bom1.stableserver.net & s13840.bom1.stableserver.net

Resolved May 12, 2026 15:26 UTC

Incident Updates

  • Resolved May 12, 2026 16:25 UTC

    We've now resolved the incident. Thanks for your patience.

  • Resolved May 12, 2026 15:26 UTC

    We are aware that some clients are experiencing problems with our services connected to servers s13839.bom1.stableserver.net & s13840.bom1.stableserver.net. Our infrastructure team are working on it as a priority. Please stand by for further updates. For immediate assistance, please don't hesitate to reach out!