Server Disruption
Resolved
Apr 29, 2026 15:21 UTC
Incident Updates
-
Resolved Apr 29, 2026 16:33 UTC
We've now resolved the incident. Thanks for your patience.
-
Resolved Apr 29, 2026 15:21 UTC
The next servers are currently down, impacting all hosted services and virtual machines. ns42.hostforweb.net new-server.lilyis.com sandiego.hostforweb.net ssdvps211.servershost.net Our team is actively working to identify the root cause and restore services. We will provide an update as soon as more information becomes available.