High traffic detected to multiple servers
Resolved
Jan 31, 2026 16:22 UTC
Incident Updates
-
Resolved Jan 31, 2026 18:04 UTC
We've now resolved the incident. Thanks for your patience.
-
Resolved Jan 31, 2026 17:10 UTC
Traffic are going back to normal. We are still actively monitoring to ensure that the service are stabilised. Thank you for understanding
-
Resolved Jan 31, 2026 16:22 UTC
We have identified some higher than normal traffic on some of our servers. Identified servers are but not limited to; s1320.sgp1.mysecurecloudhost.com s1324.sgp1.mysecurecloudhost.com s1327.sgp1.mysecurecloudhost.com Due to this, customers who have hosting and website services may be experiencing intermittent issues accessing their website. Our infrastructure team are investigating are already working toward a solution. We will keep you updated as soon as possible