Brief Server Issue
Resolved
Dec 22, 2025 23:16 UTC
Incident Updates
-
Resolved Dec 22, 2025 23:16 UTC
We are aware of a few customers that have had intermittent access issues to their services. The servers that were briefly effected are as follows: - s822.use1.mysecurecloudhost.com - s884.use1.mysecurecloudhost.com - s930.use1.mysecurecloudhost.com The time effected: 22:08 PST > 22:12 PST Our infrastructure team have implemented a fix and we have seen functionality return to normal. We appreciate your patience during this time, please contact us if you require further assistance.