Server load issue | pl4308.mex1.stableserver.net
Resolved
Nov 12, 2025 19:08 UTC
Incident Updates
-
Resolved Nov 12, 2025 22:26 UTC
We've now resolved the incident. Thanks for your patience.
-
Resolved Nov 12, 2025 19:50 UTC
We’ve located the core issue and have applied the fixes. We are now waiting for things to recover.
-
Resolved Nov 12, 2025 19:08 UTC
We are aware of a few customers having intermittent disruptions to our services connected to server pl4308.mex1.stableserver.net Our infrastructure team are working on this as a priority to resolve this matter. If you need any assistance in the immediate, please reach out to our Customer Care Team.