Server Incident Report
Resolved
Sep 11, 2025 17:34 UTC
Incident Updates
-
Resolved Sep 11, 2025 20:01 UTC
We've now resolved the incident. Thanks for your patience.
-
Resolved Sep 11, 2025 17:34 UTC
We are currently experiencing a CPU exception on server p1409.use1.mysecurecloudhost.com. This is affecting all services hosted on this server. Our team is actively working to reboot the server and restore functionality as quickly as possible.