Service latency connected to server win04.tmd.cloud
Resolved
Sep 10, 2025 01:22 UTC
Incident Updates
-
Resolved Sep 10, 2025 01:50 UTC
We've now resolved the incident and all service under the server win04.tmd.cloud should function normally. Thanks for your patience.
-
Resolved Sep 10, 2025 01:22 UTC
We’re aware that some customers may be experiencing intermittent disruptions on server win04.tmd.cloud. Our infrastructure team is actively working on this and treating it as a top priority. Thank you for your patience while we resolve the matter. If you need any immediate assistance, please don’t hesitate to reach out to our Customer Care Team.