win10.tmd.cloud
Resolved
Jun 4, 2025 11:42 UTC
Incident Updates
-
Resolved Jun 4, 2025 12:20 UTC
We've now resolved the incident. Thanks for your patience.
-
Resolved Jun 4, 2025 11:42 UTC
We're currently experiencing a connectivity issue affecting the server win10.tmd.cloud. The engineering team is already investigating it. If you need any assistance in the immediate, please reach out to our Customer Care Team.