M
← Back to status

Roundcube Webmail Access Issue

Resolved May 30, 2025 08:25 UTC

Incident Updates

  • Resolved May 30, 2025 09:10 UTC

    We've now resolved the incident. Thanks for your patience.

  • Resolved May 30, 2025 08:25 UTC

    Some users are currently unable to access their Roundcube Webmail accounts. We are working on a fix and will update this thread once the issue is resolved across all servers.