Temporary performance issues
Incident Updates
-
Resolved Mar 31, 2025 11:06 UTC
Our infrastructure team have confirmed that the incident has now been resolved. We want to thank our clients for the patience they've had whilst our team was working on this resolution. If you have further issues please don't hesitate to reach out to our Customer Care team.
-
Resolved Mar 31, 2025 11:00 UTC
We're pleased to let you know that most of our services are now fully operational. Server s291.lon1.prowebpanel.com is still being looked into, and our infrastructure team is working to resolve the issue. We're keeping a close eye on the situation and will share updates as soon as we have more information. We will continue to monitor to ensure this is fully resolved. Thank you for your patience and understanding
-
Resolved Mar 31, 2025 10:47 UTC
We are currently experiencing an issue that is affecting some of our servers. Our infrastructure team is aware of the situation and is actively working to resolve it as quickly as possible. We appreciate your patience and understanding during this time. The affected servers are: d981.lon1.mysecurecloudhost.com d3160.lon1.stableserver.net s939.lon1.mysecurecloudhost.com d980.lon1.mysecurecloudhost.com d1054.lon1.mysecurecloudhost.com d234.lon1.prowebpanel.com d1288.lon1.mysecurecloudhost.com d3134.lon1.stableserver.net d1267.lon1.mysecurecloudhost.com s955.lon1.mysecurecloudhost.com d741.lon1.mysecurecloudhost.com d736.lon1.mysecurecloudhost.com d742.lon1.mysecurecloudhost.com d224.lon1.prowebpanel.com domainservices.whgi.net d738.lon1.mysecurecloudhost.com d1076.lon1.mysecurecloudhost.com d264.lon1.prowebpanel.com d3150.lon1.stableserver.net We will provide regular updates and let you know once the issue has been resolved. If you need any assistance in the immediate, please reach out to our support team