My Secure Cloud Host
← Back to status

Hosting Performance Degradation | s1316.sgp1.mysecurecloudhost.com

Resolved Jul 9, 2026 09:21 UTC

Incident Updates

  • Resolved Jul 9, 2026 13:49 UTC

    We would like to give the update that all network and server loads are at normal levels and services are stable. 
If you have any questions or need any urgent assistance with your services, please reach out to us.

  • Recovering Jul 9, 2026 10:13 UTC

    Our system engineers applied a fix by assigning some new IP's and all services should be functioning as normal. For clients using our name servers: No action is required For clients using external name servers: They need to manually update their records. They can find their new IP in cPanel => Shared IP Address. Thank you for understanding.

  • Investigating Jul 9, 2026 09:21 UTC

    We are aware of a few customers experiencing some intermittent disruptions to their services due to higher than normal internet traffic to server s1316.sgp1.mysecurecloudhost.com. Hosting and website services might be briefly unavailable. Our infrastructure team are currently investigating and working on a fix as a priority.