My Secure Cloud Host
← Back to status

WebHostingBuzz - Client Login Issue Identified

Resolved Jul 18, 2026 11:32 UTC

Incident Updates

  • Resolved Jul 18, 2026 12:07 UTC

    Our team have confirmed that the issue with accessing your account has now been resolved. We will continue to monitor and we thank everyone for your patience.   Please reach out to us if you require further support.

  • Identified Jul 18, 2026 11:32 UTC

    We've identified a partial networking issue affecting connectivity from some non-US locations, primarily London (LON). As a result, some customers may experience difficulty logging in through the customer panel. Website and email services remain fully operational. Our infrastructure team is working closely with our upstream provider to restore normal connectivity as quickly as possible. If you require immediate assistance, please contact our Support team and we'll be happy to assist.