My Secure Cloud Host
← Back to status

Service Disruption - h119.sgp1.whgi.net

Resolved Aug 5, 2026 01:27 UTC

Incident Updates

  • Resolved 3 weeks ago · Aug 5, 2026 04:44 UTC

    Our Infrastructure team completed the necessary checks and restored normal service. The server is now operating as expected. We apologize for the disruption and appreciate your patience and understanding. If you need any assistance in the immediate, please contact our team as soon as possible.

  • Identified 3 weeks ago · Aug 5, 2026 04:43 UTC

    We are aware of a few customers had intermittent disruptions to services related to h119.sgp1.whgi.net. Our Infrastructure team are worked on this as a priority to resolve this matter. If you need any assistance in the immediate, please contact our team as soon as possible.