My Secure Cloud Host
← Back to status

Phone-Support Issue Identified

Resolved Aug 6, 2026 14:38 UTC

Incident Updates

  • Resolved Aug 6, 2026 16:27 UTC

    Our team have confirmed that the issue with the phone platform has now been resolved. We want to thank our clients for the patience they've had with us whilst working on getting things up and running. Please reach out to us if you require further support!

  • Investigating Aug 6, 2026 14:38 UTC

    We are currently experiencing some issues connected to our phone support resulting in limited availability. Our team is investigating the issue and we will provide the next update as soon as possible.   During this time, our team is still here and ready to assist. For any urgent assistance please live-chat with us, you can also create a support ticket via your client-area.