Server Latency
Incident Updates
-
Resolved Aug 6, 2026 23:45 UTC
Our technicians have confirmed that the issue should now been resolved. We want to thank our clients for the patience they've had whilst our team was working on this resolution and apologize for any of the inconveniences caused. If you have further issues, please don't hesitate to reach out to us.
-
Recovering Aug 6, 2026 22:50 UTC
Server performance is recovering, and response times are returning to normal. Some users may continue to experience intermittent delays while systems fully stabilize. Our infrastructure team is closely monitoring the recovery and will provide another update once normal performance has been fully restored.
-
Identified Aug 6, 2026 21:40 UTC
We are currently experiencing increased server latency, which may cause slower response times or intermittent delays. Our infrastructure team is actively investigating the issue and working to restore normal performance as quickly as possible. We will provide another update as soon as more information is available.