Windows server security updates
Investigating
Aug 12, 2026 10:28 UTC
Incident Updates
-
Investigating Aug 12, 2026 10:28 UTC
As part of our commitment to continually improve our systems and services, we will be performing routine maintenance on our windows servers. There will be a brief period of maintenance in order to apply security updates for these platforms. You may experience temporary interruptions during these times, after the maintenance period has ended, your service will resume as normal. If you have further questions on the maintanance, please don't hesitate to contact us.