Service Disruption — buffalo2.texaserve.com
Resolved
Aug 19, 2026 19:30 UTC
Incident Updates
-
Resolved 14 hours ago · Aug 19, 2026 20:42 UTC
Our technicians have confirmed that the buffalo2.texaserve.com issue has now been resolved. We want to thank our clients for the patience they've had whilst our team was working on this resolution and apologise again for any of the inconveniences caused. If you have further issues please don't hesitate to reach out to us.
-
Investigating 15 hours ago · Aug 19, 2026 19:30 UTC
The server buffalo2.texaserve.com has experienced a crash, resulting in an interruption to all services hosted on the affected system. Our team is actively investigating the issue and working to restore services as quickly as possible.