My Secure Cloud Host
← Back to status

Hosting Issue - Identified

Resolved Aug 23, 2026 10:28 UTC

Incident Updates

  • Resolved 3 days ago · Aug 23, 2026 10:58 UTC

    The network incident affecting the c100.use1 cluster has been resolved, and services have returned to normal operation. If you continue to experience any issues with your services, please contact our support team. We appreciate your patience and apologize for any inconvenience caused.

  • Investigating 3 days ago · Aug 23, 2026 10:56 UTC

    We are investigating a network incident affecting the c100.use1 cluster. During the incident, network flaps may have caused some domains and IP addresses hosted on the affected servers to become intermittently unreachable. Our infrastructure team is working on this as a priority to restore stable connectivity. If you require immediate assistance, please contact our support team so we can assist you further.