My Secure Cloud Host
← Back to status

Hosting Issue - Identified - DXB1 servers

Resolved Aug 29, 2026 09:04 UTC

Incident Updates

  • Resolved 1 week ago · Aug 29, 2026 11:15 UTC

    The connectivity and packet loss issues affecting servers in our Dubai (DXB1) region have been resolved. Connectivity has been restored, and affected services are operating normally. We apologize for any disruption this may have caused and appreciate your patience while our infrastructure team worked to resolve the issue. This incident is now resolved.

  • Recovering 1 week ago · Aug 29, 2026 09:05 UTC

    Our infrastructure team have implemented a fix and are seeing functionality return to normal. We appreciate your patience during this time. We will continue to monitor to ensure this is fully resolved.

  • Investigating 1 week ago · Aug 29, 2026 09:04 UTC

    We are currently investigating packet loss and intermittent connectivity issues affecting servers in our Dubai (DXB1) region. Customers may experience intermittent connectivity to their websites or management services. Our infrastructure team is actively investigating the issue and working to restore stable connectivity. We will provide another update as soon as we have more information.