My Secure Cloud Host
← Back to status

Network Connectivity Issues in Latin America

Investigating Sep 6, 2026 01:19 UTC

Incident Updates

  • Investigating 8 hours ago ยท Sep 6, 2026 01:19 UTC

    We are currently investigating intermittent network connectivity affecting customers located in the Latin America (LATAM) region. Impacted users may experience: -Slow loading times when accessing hosted websites -Delays or intermittent errors when logging into cPanel / server management portals -Temporary inability to connect to services Our Infrastructure and Network Engineering teams are actively tracing routing paths and investigating the root cause to restore full performance. Note: Systems are fully operational outside of LATAM. Further updates will be provided as soon as additional details or a timeline for resolution become available.