DDOS on 2900.fra1.stableserver.net, s2909.fra1.stableserver.net and s605.fra8.mysecurecloudhost.com Wednesday 5th June 2024 18:02:00


Update @ 23:12 UTC Monday - All services are operating normally. We have paused migrations tonight and will migrate the rest of the accounts on Tuesday evening. We will send emails confirming the new IP first.


UPDATE - s605.fra8.mysecurecloudhost.com's accounts will be getting migrated over to a new server later today/tonight.

2900.fra1.stableserver.net, s2909.fra1.stableserver.net and s605.fra8.mysecurecloudhost.com were under DDOS attacks today. We have taken steps to mitigate the issue, but users may experience slower than normal services on those servers.